CVE-2026-75913

HIGH
MEDIUM Priority: 0.04 BB Relevance: 67/100
Published: 2026-08-18 Modified: 2026-10-29 First seen: 2026-10-29 Status: active

Attack Surface

Network Low Complexity No Auth Integ. Impact

CVSS Vector Breakdown

AV: Network
AC: Low
PR: None
UI: Passive
AT: None
VC: None
VI: High
VA: High

Description

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

Weakness Classification (1)

Affected Software (8)

VendorProductVersion
Hmbown CodeWhale 0.3.27
Hmbown CodeWhale 0.3.27 < 0.8.41
Hmbown CodeWhale 0.8.41 < 0.8.64
Hmbown CodeWhale 0.8.41 < 0.8.64
Hmbown CodeWhale 0.3.27
Hmbown CodeWhale 0.3.27 < 0.8.41
Hmbown CodeWhale 0.8.41 < 0.8.64
Hmbown CodeWhale 0.8.41 < 0.8.64

Bug Bounty Relevance

67 / 100
✓ Network accessible
✓ No authentication
✓ Low complexity

CVSS Score

8.5 / 10.0 v4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H

EPSS — Exploitation Probability

0.48%
Raw Score 0.004770
Percentile 41.1%
Date 2026-10-29

EPSS Trend

2026-10-29
0.00477
2026-10-28
0.00477

Intelligence Sources

mitre ref →
nvd ref →