CVE-2026-54232

HIGH
MEDIUM Priority: 0.05 BB Relevance: 68/100
Published: 2026-06-22 Modified: 2026-10-25 First seen: 2026-10-29 Status: active

Attack Surface

Network Low Complexity No Auth Conf. Impact Integ. Impact

CVSS Vector Breakdown

AV: Network
AC: Low
PR: None
UI: Required
S: Unchanged
C: High
I: High
A: High

Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

Weakness Classification (1)

Affected Software (1)

VendorProductVersion
vllm vllm < 0.22.1

References & Advisories (1)

Bug Bounty Relevance

68 / 100
✓ Network accessible
✓ No authentication
✓ Low complexity

CVSS Score

8.8 / 10.0 v3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS — Exploitation Probability

0.56%
Raw Score 0.005630
Percentile 46.7%
Date 2026-10-29

EPSS Trend

2026-10-29
0.00563
2026-10-28
0.00563

Intelligence Sources

nvd ref →