CVE-2026-49871

LOW
INFO Priority: 0.01 BB Relevance: 54/100
Published: 2026-06-19 Modified: 2026-10-26 First seen: 2026-10-29 Status: active

Attack Surface

Network Low Complexity No Auth

CVSS Vector Breakdown

AV: Network
AC: Low
PR: None
UI: Active
S: X
AT: Present
VC: None
VI: None
VA: None

Description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness Classification (1)

Affected Software (1)

VendorProductVersion
apache apisix 3.0.0 – 3.17.0

References & Advisories (2)

Bug Bounty Relevance

54 / 100
✓ Network accessible
✓ No authentication
✓ Low complexity

CVSS Score

2.1 / 10.0 v4.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

EPSS — Exploitation Probability

0.35%
Raw Score 0.003510
Percentile 28.7%
Date 2026-10-29

EPSS Trend

2026-10-29
0.00351
2026-10-28
0.00351

Intelligence Sources

nvd ref →