CVE-2026-49042
HIGH
MEDIUM
Priority: 0.05
BB Relevance:
75/100
Published: 2026-07-06
Modified: 2026-10-25
First seen: 2026-10-29
Status: active
Attack Surface
Network
Low Complexity
No Auth
No Interaction
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
None
UI:
None
S:
Unchanged
C:
Low
I:
Low
A:
Low
Description
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Weakness Classification (1)
References & Advisories (2)
Vendor Advisory
Patch
Third Party Advisory