CVE-2026-46588

HIGH
MEDIUM Priority: 0.05 BB Relevance: 75/100
Published: 2026-07-06 Modified: 2026-10-25 First seen: 2026-10-29 Status: active

Attack Surface

Network Low Complexity No Auth No Interaction

CVSS Vector Breakdown

AV: Network
AC: Low
PR: None
UI: None
S: Unchanged
C: Low
I: Low
A: Low

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Weakness Classification (1)

Affected Software (1)

VendorProductVersion
apache camel 4.0.0 – 4.14.8

References & Advisories (2)

Bug Bounty Relevance

75 / 100
✓ Network accessible
✓ No authentication
✓ Low complexity
✓ No user interaction

CVSS Score

7.3 / 10.0 v3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

EPSS — Exploitation Probability

0.69%
Raw Score 0.006920
Percentile 52.8%
Date 2026-10-29

EPSS Trend

2026-10-29
0.00692
2026-10-28
0.00692

Intelligence Sources

nvd ref →