CVE-2026-44580

MEDIUM
MEDIUM Priority: 0.01 BB Relevance: 62/100
Published: 2026-05-13 Modified: 2026-10-26 First seen: 2026-10-29 Status: active

Attack Surface

Network Low Complexity No Auth Scope Change

CVSS Vector Breakdown

AV: Network
AC: Low
PR: None
UI: Required
S: Changed
C: Low
I: Low
A: None

Description

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness Classification (1)

Affected Software (1)

VendorProductVersion
vercel next.js 13.0.0 – 15.5.16

References & Advisories (1)

Bug Bounty Relevance

62 / 100
✓ Network accessible
✓ No authentication
✓ Low complexity

CVSS Score

6.1 / 10.0 v3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

EPSS — Exploitation Probability

0.21%
Raw Score 0.002050
Percentile 10.5%
Date 2026-10-29

EPSS Trend

2026-10-29
0.00205
2026-10-28
0.00205

Intelligence Sources

nvd ref →