CVE-2026-42268
HIGH
MEDIUM
Priority: 0.03
BB Relevance:
76/100
Published: 2026-05-12
Modified: 2026-10-26
First seen: 2026-10-29
Status: active
Attack Surface
Network
Low Complexity
No Auth
No Interaction
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
None
UI:
None
S:
X
AT:
Present
VC:
None
VI:
None
VA:
High
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
Affected Software (1)
| Vendor | Product | Version |
|---|---|---|
| owasp | modsecurity | 3.0.0 – 3.0.15 |
References & Advisories (1)
Exploit
Vendor Advisory