CVE-2026-40176

HIGH 3 PoCs
MEDIUM Priority: 0.08 BB Relevance: 51/100
Published: 2026-04-15 Modified: 2026-11-02 First seen: 2026-11-02 Status: active

Attack Surface

Low Complexity No Auth Conf. Impact Integ. Impact

CVSS Vector Breakdown

AV: Local
AC: Low
PR: None
UI: Required
S: Unchanged
C: High
I: High
A: High

Description

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

Weakness Classification (2)

Affected Software (3)

VendorProductVersion
composer composer >= 2.3, < 2.9.6
composer composer >= 1.0, < 2.2.27
getcomposer composer 1.0.0 – 2.2.26

Bug Bounty Relevance

51 / 100
✓ No authentication
✓ Low complexity
✓ PoC available (3)

CVSS Score

7.8 / 10.0 v3.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS — Exploitation Probability

1.04%
Raw Score 0.010450
Percentile 64.3%
Date 2026-11-05

EPSS Trend

2026-11-05
0.01045
2026-11-04
0.01045
2026-11-03
0.01045
2026-11-02
0.01045

Intelligence Sources

mitre ref →
nvd ref →