CVE-2026-31923
HIGH
MEDIUM
Priority: 0.02
BB Relevance:
75/100
Published: 2026-04-14
Modified: 2026-10-26
First seen: 2026-10-29
Status: active
Attack Surface
Network
Low Complexity
No Auth
No Interaction
Conf. Impact
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
None
UI:
None
S:
Unchanged
C:
High
I:
None
A:
None
Description
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Weakness Classification (1)
References & Advisories (2)
Mailing List
Vendor Advisory
Mailing List
Third Party Advisory