CVE-2026-24098
MEDIUM
MEDIUM
Priority: 0.05
BB Relevance:
63/100
Published: 2026-02-09
Modified: 2026-11-03
First seen: 2026-11-03
Status: active
Attack Surface
Network
Low Complexity
No Interaction
Conf. Impact
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
Low
UI:
None
S:
Unchanged
C:
High
I:
None
A:
None
Description
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue
Weakness Classification (1)
Affected Software (3)
| Vendor | Product | Version |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 3.0.0 < 3.1.7 |
| Apache Software Foundation | Apache Airflow | 3.0.0 < 3.1.7 |
| apache | airflow | 3.0.0 – 3.1.7 |
References & Advisories (3)
vendor-advisory
patch
Mailing List
Third Party Advisory