CVE-2026-120597
LOW
INFO
Priority: 0.01
BB Relevance:
54/100
Published: 2026-11-02
Modified: 2026-11-03
First seen: 2026-11-02
Status: active
Attack Surface
Network
Low Complexity
No Auth
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
None
UI:
Passive
S:
X
AT:
None
VC:
None
VI:
Low
VA:
None
Description
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Weakness Classification (2)
Affected Software (14)
| Vendor | Product | Version |
|---|---|---|
| Welcart | e-Commerce Plugin | 2.12.0 |
| Welcart | e-Commerce Plugin | 2.12.1 |
| Welcart | e-Commerce Plugin | 2.12.2 |
| Welcart | e-Commerce Plugin | 2.12.3 |
| Welcart | e-Commerce Plugin | 2.12.4 |
| Welcart | e-Commerce Plugin | 2.12.5 |
| Welcart | e-Commerce Plugin | 2.12.6 |
| Welcart | e-Commerce Plugin | 2.12.0 |
| Welcart | e-Commerce Plugin | 2.12.1 |
| Welcart | e-Commerce Plugin | 2.12.2 |
| Welcart | e-Commerce Plugin | 2.12.3 |
| Welcart | e-Commerce Plugin | 2.12.4 |
| Welcart | e-Commerce Plugin | 2.12.5 |
| Welcart | e-Commerce Plugin | 2.12.6 |
References & Advisories (6)
vdb-entry
technical-description
third-party-advisory
third-party-advisory
signature
permissions-required
patch
exploit