CVE-2026-116593
INFO
Priority: 0.00
BB Relevance:
0/100
Published: 2026-10-28
Modified: 2026-10-29
First seen: 2026-10-29
Status: pending_score
Description
Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker. Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.
Affected Software (8)
| Vendor | Product | Version |
|---|---|---|
| Apache Software Foundation | Apache Kafka | 2.4.0 < 4.2.2 |
| Apache Software Foundation | Apache Kafka | 4.3.0 < 4.3.2 |
| Apache Software Foundation | Apache Kafka | 2.4.0 < 4.2.2 |
| Apache Software Foundation | Apache Kafka | 4.3.0 < 4.3.2 |
| Apache Software Foundation | Apache Kafka | 2.4.0 < 4.2.2 |
| Apache Software Foundation | Apache Kafka | 4.3.0 < 4.3.2 |
| Apache Software Foundation | Apache Kafka | 2.4.0 < 4.2.2 |
| Apache Software Foundation | Apache Kafka | 4.3.0 < 4.3.2 |