CVE-2025-68675
HIGH
MEDIUM
Priority: 0.14
BB Relevance:
75/100
Published: 2026-01-16
Modified: 2026-11-03
First seen: 2026-11-03
Status: active
Attack Surface
Network
Low Complexity
No Auth
No Interaction
Conf. Impact
CVSS Vector Breakdown
AV:
Network
AC:
Low
PR:
None
UI:
None
S:
Unchanged
C:
High
I:
None
A:
None
Description
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed. Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue
Weakness Classification (1)
Affected Software (5)
| Vendor | Product | Version |
|---|---|---|
| Apache Software Foundation | Apache Airflow | 0 < 2.11.1 |
| Apache Software Foundation | Apache Airflow | 3.0.0 < 3.1.6 |
| Apache Software Foundation | Apache Airflow | 0 < 2.11.1 |
| Apache Software Foundation | Apache Airflow | 3.0.0 < 3.1.6 |
| apache | airflow | < 3.1.6 |
References & Advisories (3)
vendor-advisory
patch
Mailing List
Third Party Advisory